Le Lievre et la tortue par Algobox

 

 


Problème :

Un lièvre et une tortue décident de faire une course. Ils procèdent en lançant un dé à 6 faces non pipé. Lorsque le 6 apparaît, le lièvre gagne, sinon la tortue avance d'une case jusqu'à ce qu'elle en ait parcouru  6, et alors elle gagne.

Qui des deux a le plus de chances de gagner ?



Voici l'algorithme généré par algobox qui teste cette fameuse course du lièvre et de la tortue.
J'utilise cet alogorithme dans une activité de seconde, où on fait successivement des simulations avec un dé, puis la calculatrice, puis un tableur, et enfin avec cet algorithme généré par Algobox.
Vous pouvez le tester en ligne en appuyant sur le bouton "Lancer l'algorithme".
Il donne les résultats du lancer des dés et affiche aussi le gagnant.

En théorie, on peut montrer que la probabilité que la tortue gagne est de 1/3 environ. 



Tester l'algorithme :


(cliquer sur le bouton ci-dessus pour lancer ou relancer l'exécution de l'algorithme)
Remarque : si les messages "Algorithme lancé" et "Algorithme terminé" n'apparaissent pas au bout d'un moment dans la zone ci-dessous, c'est que l'algorithme contient une erreur.

Résultats :


Code de l'algorithme :
1     VARIABLES
2      
 n EST_DU_TYPE NOMBRE
3      
 L EST_DU_TYPE NOMBRE
4      
 T EST_DU_TYPE NOMBRE
5    
 DEBUT_ALGORITHME
6      
 T PREND_LA_VALEUR 0
7      
 L PREND_LA_VALEUR 0
8      
 TANT_QUE (L<6 ET T<6) FAIRE
9        
 DEBUT_TANT_QUE
10       
 n PREND_LA_VALEUR floor(random()*6+1)
11       
 AFFICHER n
12       
 SI (n!=6) ALORS
13         
 DEBUT_SI
14         
 T PREND_LA_VALEUR T+1
15         
 FIN_SI
16         
 SINON
17           
 DEBUT_SINON
18           
 L PREND_LA_VALEUR 6
19           
 FIN_SINON
20       
 FIN_TANT_QUE
21     
 SI (T==6) ALORS
22       
 DEBUT_SI
23       
 AFFICHER "la tortue gagne"
24       
 FIN_SI
25       
 SINON
26         
 DEBUT_SINON
27         
 AFFICHER "le lièvre gagne"
28         
 FIN_SINON
29   
 FIN_ALGORITHME

Créer un site gratuit avec e-monsite - Signaler un contenu illicite sur ce site

×